iframeで埋め込まれたDocuSignセッションが空白ページで表示される

問題

サポートされているWebブラウザーで埋め込まれたDocuSignセッション(署名セッションまたは送信セッション)を開くと、 空白ページが表示されたり、Webブラウザーがサポートされないという内容のメッセージが表示されたりする(Internet Explorer)。

blank screen and unsupported browser error in iframe

原因

この問題は、「互換表示」モードのWebブラウザーで発生します。サポートされているバージョンのInternet Explorerで、ドキュメントモードで非サポートバージョンが選択されている場合があります。たとえば、Internet Explorer 11のデフォルトでは、ドキュメントモードがIE5に設定されます。

解決方法

  1. DocuSignのWebサイト、および内部ドメイン/Webサイトに対し、互換表示を無効にします。
a.  Internet Explorerで、[設定]Internet Explorer Settings をクリックします。
b. [互換表示設定] をクリックします。
c. [互換表示に追加したWebサイト]リストで、[docusign.net]および自分の内部ドメインを選択して[削除]
をクリックします。
d. [イントラネットサイトを互換表示で表示する]チェックボックスをオフにします。
e. [閉じる]をクリックします。
f. Webページをリロードします。
  1. 互換表示を有効にしたまま、ドキュメントモードで適切なバージョンを選択します。互換表示機能を無効にできない環境では、この方法を使用します。
a.  Internet Explorerを起動し、F12キーを押して[F12開発者ツール]を開きます。
b. [エミュレーション]をクリックします。
c. [ドキュメントモード]ドロップダウンメニューから、9またはそれ以降のバージョン(Edge推奨)を選択します。
d. Webページをリロードします。
注: APIで署名セッションや送信セッションを開く場合は、自社インテグレーションから新しいトークンを生成する必要があります。
change document mode

重要

互換表示の変更でこの問題が解決されない場合は、以下の対策を検討してください。


追加情報

  • 特にモバイルデバイスなどで、DocuSignセッションをiframe内で起動することはお勧めしません。iframe内での起動が必要な場合は、インテグレーションの所有者に問い合わせてください。
  • 上記の一部の設定は、IT部署により管理されている場合があります。このトピックの手順どおりに操作できない場合は、IT部署に問い合わせてください。

リソース

Embedded Sending & Signing | DocuSign API
署名するときのシステム要件 - 署名者ガイド