DocuSign APIとConnectインテグレーションのエラー: このアカウントには必要な権限がありません - アカウントのDocuSign Connectが有効になっていません

問題

DocuSign APIとConnectを使用したインテグレーションで、「This Account lacks sufficient permissions. :: Connect not enabled for account.(このアカウントには必要な権限がありません。アカウントのDocuSign Connectが有効になっていません)」というエラーが発生する。

原因

多くのDocuSign APIインテグレーションでConnect関連の要求が送信されます(例: SAP SuccessFactorsWorkdayなど)。このエラーは、Connect機能が完全に有効になっていないアカウントのDocuSign Connect設定をAPIで取得、作成、更新、または削除しようとすると発生します。

この問題は、Connect機能が以下の場合に発生します。
  1. 許可されておらず無効になっている
または
  1. 許可されていても有効になっていない

解決策

注: 以下の手順では、DocuSign APIをコールするインテグレーションが正しいアカウントおよび環境に正しい資格情報で接続済みであることを前提としています。詳しくは、インテグレーションの所有者またはIT部門に問い合わせてください。

まず、原因が上記の1.であるか2.であるかを確認します。

  1. アカウント管理者としてDocuSign eSignatureにログインします。
  2. ページ上部の[設定]タブをクリックします。
  3. 左側のパネルの[インテグレーション]セクションに[DocuSign Connect]が表示されていることを確認します。
DS Admin Integrations Sidebar - Connect
  • [DocuSign Connect]が表示されていない場合、Connectの使用が許可されておらず、有効にもなっていません(上記原因の1.)。次の手順4.に進みます。
  • [DocuSign Connect]が表示されている場合、Connectの使用は許可されていても有効になっていません(上記原因の2.)。手順5.に進みます。
  1. アカウントでのConnectの使用を許可するには、DocuSignサポートセンターでケースを作成する必要があります。その後で、手順5.に進みます。
  2. [DocuSign Connect]をクリックします。「Connectが無効です」というメッセージが表示されます。
DS Admin Connect Not Enabled
  1. [Connectを有効にする]をクリックします。
  2. インテグレーションでの動作を再確認します。

リソース