DocuSign eSignature for Salesforce - エラー「ユーザーに十分なアクセス権がないか、エンベロープが存在しないため、このエンベロープは表示できません」
この問題は、DocuSign eSignature for Salesforceで発生します。
問題
[DocuSignで送信]ボタンをクリックしたときに「ユーザーに十分なアクセス権がないか、エンベロープが存在しないため、このエンベロープは表示できません」というエラーが表示される。
原因
すべてのユーザーが送信できない場合: System Senderの資格情報が正しくない。特定のユーザーが送信できない場合: そのユーザーのプロファイルに問題がある。ユーザーのメンバーシップ情報のレコードは、そのユーザーのSalesforceユーザープロファイル内に「DocuSign Username」(古いバージョンでは「DSproSFusername」)として格納されます。クローズ済みのユーザーやSystem Senderアカウントに関連付けられていないユーザーなど、この項目が空白である場合にこのエラーが発生します。また、そのユーザーがアクティブなDocuSignユーザーでない場合にも、この問題が発生します。
解決方法1
システム全体の動作およびSystem Senderの修正
- Salesforce環境に管理者としてログインします。
- [DocuSign管理]タブを開きます。
- [アカウント]タブをクリックします。
- 設定されているアカウント名およびメタデータを確認します。
- [アカウント設定の変更]をクリックします。
- 必要な場合は、[環境]ドロップダウンで環境を選択します。
- メンバーシップに複数のアカウントが関連付けられている場合、「このメールアドレスには複数のDocuSignアカウントが関連付けられています。」というメッセージが表示されます。この場合、[アカウント]ドロップダウンでアカウントを指定します。
- 適切なアカウントを選択して再ログインします。「DocuSignアカウントのログインに成功しました」というメッセージが緑で表示されます。
- DocuSignとSalesforceとのデータ書き戻し用の関連付けを確認するメッセージが表示されます。書き戻しに問題がない場合、ここでの関連付けは不要です。
解決方法2
特定ユーザーの動作およびDocuSign Username値の修正
注: ここでは、System Senderと同じアカウントにアクティブなDocuSignユーザーのプロファイルが追加済みであることを前提としています。
- Salesforce環境に管理者としてログインします。
- [設定]を選択し、 [ユーザ]>[ユーザ]の順にクリックします。
- エラーが発生するユーザーのプロファイルを開きます。
- [DocuSign Username(以前のバージョンでは「DSProSFUsername」)]フィールドをレイアウトに追加します。
- 28文字の値が表示されたら、それをメモします。
- DocuSign eSignature Webアプリケーションに管理者としてログインします。
- [設定]>[ユーザー]の順に開き、マップするユーザーをクリックします。[APIユーザー名]セクションに表示される28文字の値とメモした値を比較し、一致していないことを確認します。
- [APIユーザー名]セクションの値をSalesforce側の[DocuSign Username]フィールドにコピーして保存します。
注: これにより、Salesforceのユーザープロファイルに、DocuSign側で選択したユーザーとしてエンベロープを送信する権限が付与されます。このため、マップするDocuSignユーザーが適切かどうかを確認する必要があります。
注意: 上記の一部の手順はDocuSign for Salesforceのバージョン7.0〜7.7.4に適用されません。設定を変更した後で、強制同期ツールを使用する必要があります。
参照: