SSO v2 - エラーメッセージ「シングルサインオン用のフェデレーションIDがこのユーザーのものと一致しま​せん。DocuSign管理者に問い合わせてください」が表示される

問題

シングルサインオン(SSO)が有効なアカウントでユーザーがDocuSignにログインするときに、エラーメッセージ「シングルサインオン用のフェデレーションIDがこのユーザーのものと一致しません。DocuSign管理者に問い合わせてください」が表示される。

考えられる原因

設定済みのフェデレーションID(「NameID」または「不変ID(Immutable ID)」と呼ばれることもあります) を更新する必要があります。フェデレーションIDは、ユーザーがログインするときの永続的な識別子として使用されます。これにより、IDプロバイダー(IdP)でのユーザーのメールアドレスの更新が可能になります。この検証は、SAMLトレースにより行われます。SAMLトレースを確認する方法については、「WebブラウザーでSAML応答を確認するには」を参照してください。

フェデレーションIDはどのように設定されるのか

フェデレーションIDが未設定のユーザーが、登録済みの名前/パスワードを使って初めてSAMLでログインすると、SAML応答のNameIDに一致するように値が設定されます。この値がDocuSign側で消去されると、次のそのユーザーがSAMLでログインしたときに値がリセットされます。

解決方法

IDプロバイダーでフェデレーションIDを元の値に戻すことをお勧めします。

これが不可能な場合は、DocuSign管理者がユーザーのフェデレーションIDをリセットします。
これは、各NameID/Immutable IDについて1つずつ行う必要があります。すべてのユーザーのIDを一括でリセットしなければならない場合は、このトピックを参照してください。

フェデレーションIDをリセットするには:

1) DocuSign管理画面のダッシュボードで[ユーザー]をクリックします。
2) 目的のユーザーを選択します。
3) [セキュリティ]タブを開きます。
4) フェデレーションIDとIDプロバイダーのリストが表示されます。リセットするフェデレーションIDの[クリア]をクリックします。