Pourquoi mes paramètres de rappel ne sont-ils pas respectés ?

Problème
Après une mise à jour des paramètres de rappel et d'expiration d’un compte, les enveloppes continuent d’utiliser les anciens paramètres.

Cause
L’enveloppe a été créée avant la modification des paramètres ou les paramètres sont remplacés par des paramètres configurés autre part.

Solution
Il est important de noter que la majorité des paramètres de compte dans votre compte DocuSign ne sont pas rétroactifs. Autrement dit, lorsque vous modifiez un paramètre de votre compte, cette modification ne s’applique généralement pas aux enveloppes déjà en cours de traitement. La modification s’appliquera uniquement aux nouvelles enveloppes créées après la modification du paramètre. Les paramètres configurés dans Rappels et Expirations (dans le panneau Admin) se comportent de cette manière. Si vous mettez à jour ces paramètres, ils deviennent les nouvelles valeurs par défaut pour tous les utilisateurs de votre compte à partir de ce moment-là.

Si vous constatez que les paramètres de rappel et d’expiration utilisés sont incorrects sur une enveloppe qui a été créée après que vous avez mis à jour les paramètres du compte, cela signifie généralement que les paramètres du compte ont été remplacés par une autre source.
DocuSign autorise la désignation des paramètres de rappel et d’expiration pour une enveloppe dans plusieurs emplacements. De ce fait, une hiérarchie des priorités a été établie. La hiérarchie (de la priorité la plus élevée à la plus basse) se présente comme suit :

  1. Appel d’API
  2. Saisie de l’expéditeur
  3. Paramètres du modèle
  4. Paramètres par défaut du compte

Si une enveloppe est créée directement dans l’interface DocuSign et qu’aucun modèle n’est utilisé, l’enveloppe utilisera les paramètres par défaut du compte.

Si une enveloppe est créée et qu’un modèle est appliqué à celle-ci, l’enveloppe utilisera les paramètres du modèle au lieu des paramètres du compte.

Si le compte a été configuré pour autoriser les expéditeurs à choisir leurs propres paramètres de rappel et d’expiration, toute valeur saisie par l’expéditeur sera utilisée au lieu des paramètres par défaut du compte. Si l’expéditeur applique un modèle, l’enveloppe utilisera les paramètres fournis par la source la plus récente. Cela signifie que si l’expéditeur définit les paramètres de rappel et d’expiration dans l’enveloppe, puis applique un modèle par la suite, les paramètres du modèle seront appliqués et la configuration manuelle de l’expéditeur sera ignorée. L’expéditeur a la possibilité de modifier les paramètres de rappel et d’expiration après avoir appliqué un modèle (tant que le modèle et le compte le permettent). La modification de ces paramètres après l’application du modèle permet de s’assurer que les saisies manuelles de l’expéditeur sont utilisées.

Si une enveloppe utilise plusieurs modèles, les paramètres de rappel et d’expiration provenant du dernier modèle à appliquer à l’enveloppe seront utilisés. Comme précisé ci-dessus, un expéditeur peut modifier manuellement ces paramètres après avoir appliqué tous les modèles, et les saisies manuelles seront utilisées à la place des valeurs contenues dans le dernier modèle.

Si l’enveloppe est créée via l’API DocuSign, les instructions fournies dans l’appel d’API de ce programme auront la priorité par rapport à tous les autres paramètres. Si ce programme ne fournit aucun paramètre de rappel et d’expiration dans updateNotificationSettings, DocuSign appliquera la hiérarchie mentionnée ci-dessus.

Modèles

Lorsqu’un modèle est créé, il utilise par défaut les paramètres de rappel et d’expiration actuels du compte. Le créateur du modèle doit manuellement ajuster ces paramètres s’il souhaite utiliser des règles différentes des paramètres par défaut du compte. Une fois que le modèle est créé, il conserve les paramètres de rappel et d’expiration qu’il contient, quels qu’ils soient. Si le créateur a configuré ces paramètres manuellement, le modèle contiendra les valeurs de ces paramètres. Si le créateur n’a pas ajusté ces paramètres, leurs valeurs correspondront à celles des paramètres de rappel et d’expiration définis pour le compte à ce moment-là.

Si les paramètres de rappel et d’expiration sont modifiés ultérieurement pour le compte, aucune modification ne sera apportée aux enveloppes et modèles existants dans ce compte. Si les modèles dans votre compte ont été configurés pour utiliser les paramètres par défaut de votre compte, cela signifie que chaque modèle devra être mis à jour pour refléter les nouveaux paramètres. Un administrateur de compte doit être en mesure d’effectuer cette tâche, même si les modèles sont protégés par un mot de passe pour en empêcher la modification. Les autres utilisateurs autorisés à créer et/ou à modifier des modèles auront besoin du mot de passe pour modifier un modèle protégé par un mot de passe.

Lors de la création ou de la modification d’un modèle, vous pouvez trouver les paramètres de rappel et d’expiration dans les options avancées, qui se trouvent dans le coin supérieur droit de la page « Préparer l’enveloppe ».
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Si les options sont grisées, cela signifie que le compte a été configuré pour empêcher les expéditeurs de modifier ces paramètres.


Pour pouvoir modifier ces paramètres dans un modèle, un administrateur doit d’abord activer l’option « Permettre aux utilisateurs de passer outre ces paramètres » dans Paramètres > Rappels et Expirations.
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Une fois que cette option a été activée, vous pouvez revenir à votre modèle ; les paramètres devraient à présent être modifiables. Une fois que vous avez fini de mettre à jour vos modèles, revenez à Rappels et Expirations et désactivez à nouveau l’option « Permettre aux utilisateurs de passer outre ces paramètres » si vous le souhaitez.

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