DocuSign for Salesforce - Why do I get the error "Unable to add/update DocuSign envelopes"?

Issue

In DocuSign for Salesforce, you receive the following error:

"!Error: Unable to add/update DocuSign envelopes. DocuSign_Envelope_c: no delete access. Unable to add/update documents. DocuSign_Envelope_Document_c: no delete access. Unable to add/update recipients. DocuSign_Envelope_Recipient_c: no delete access."

Cause

This error indicates the user's Salesforce permission profile does not have the delete permission for the listed objects.

Solution:

As a Salesforce Administrator, update the Custom Object Permissions for the user.

  1. Log in to Salesforce, click profile name, then click Setup.
  2. Under Administration Setup, click to expand Manage Users, then click Profiles.
  3. Click the affected profile.
  4. Click Edit at the top of the page.
  5. Navigate to the Custom Object Permissions section near the bottom of the page and check the box for Delete on each object affected per the error message (DocuSign Envelope, DocuSign Document, DocuSign Recipient).
  6. Click Save.