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Why do I get the error "!! Email Address Required !!" when sending from DocuSign eSignature for Salesforce?
Symptom:
In DocuSign eSignature for Salesforce, you receive the following error after adding a recipient to an envelope using the Contacts, Leads, or Users buttons:
"!! Email Address Required !!"
Diagnosis:
When adding a recipient using the Contacts, Leads, or Users buttons, Salesforce pulls information from the following fields on the Contacts object:
- Fax
- Name
- Phone
- First Name
- Last Name
If these fields are not present, or if access is restricted to these fields, the !! Email Address Required !! error will occur when adding a recipient.
Solution:
To address this issue, it is important to verify the required fields are visible and that the sender's profile has access to them.
As a Salesforce Administrator, ensure the Field-Level Security is properly configured for the sender's profile:
Note: This example uses Fax, as it is the most commonly misconfigured item; however, the process for the other five items is the same.
- Log in to Salesforce, click profile name, then click Setup.
- Under App Setup, click to expand Customize, click to expand Contacts, then click Fields.
- Click Fax.
- Click Set Field-Level Security.
- Ensure Visible is checked for the Salesforce profile the user is sending from, then click Save.
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If this does not resolve the issue, repeat this process with the other five fields.