Upgrading DocuSign eSignature for Salesforce

Overview

If you are on an older DocuSign eSignature for Salesforce version (6.9 or earlier), you may encounter errors if you try to upgrade directly to the latest available version.
To ensure that the upgrade process runs smoothly, there are two options:
  1. Use the install links provided below to reach a compatible version that allows upgrade to the most recent package. 
  2. Uninstall DocuSign eSignature for Salesforce and install the most recent package from the Salesforce AppExchange.
Note: While we recommend using option 1, option 2 is a quick option if you have not used the integration or do not need any DocuSign data that is currently in your Salesforce Organization. If you have concerns on if you should uninstall vs. upgrade DocuSign eSignature for Salesforce, please reach out to Support for confirmation that uninstalling or upgrading is the best option.

How to Upgrade to a Compatible Version

To upgrade, follow the links below. Please upgrade in the order they are listed below, depending on what version you are on.
For example, if you are on 3.11, you will need to use all of the upgrade links listed, and upgrade in the order they are listed (5.6 to 6.4.5, then 6.4.5 to 6.7.2, followed by 6.7.2 to 6.8.2, etc.). Once DocuSign eSignature for Salesforce is updated to 7.0, you will be able to upgrade to any version of our package that is in the Salesforce AppExchange. 
 
Note: Any DocuSign eSignature for Salesforce 7+ version no longer supports JavaScript buttons. You will need to convert all custom JavaScript buttons to URLFOR Format. Before upgrading to a 7+ version you can remain on v6.9.4 while converting your buttons from JavaScript to URLFOR format. v6.9.4 supports both button formats. You can review the steps to convert your buttons here 

We highly recommend you test this upgrade process in your Sandbox environment first. To use these links in Sandbox, update the URL to https://test.salesforce.com.

In addition, if you are not sure what version of DocuSign eSignature for Salesforce you are using, navigate to Setup > Installed Packages in Salesforce.
In the Installed Packages list, you will see our version number next to DocuSign eSignature for Salesforce, under the Version Number column:
User-added image
Note: These links provided in this article are to be used to upgrade your current DocuSign eSignature for Salesforce integration to the most recent iteration of our integration. Please do not install these versions as a new installation, as newer versions meet required Salesforce security regulations and have product issue fixes that may affect these older versions.