SSO Email Domain Change Error - There was an error changing email, please try again later

Issue

Users on a Single Sign On enabled account attempt to change their email they receive an error “There was an error changing email, please try again later”. 

Possible Cause

If the account has “Prevent unmanaged signups” enabled, they will be unable change their email to the new domain.

Solution

“Prevent unmanaged signups” ensures that users don’t create accounts that the organization does not manage. The system will try to enforce that through all the different means to ensure there are no loopholes to this policy. This is why rename doesn’t work when this is enabled.
 
If you uncheck this box, you should be able to rename into the domain. 

User-added image