DocuSign's API and Connect Feature Integration ERROR: This Account lacks sufficient permissions - Connect not enabled for account

Issue

An integration leveraging both DocuSign's API & Connect Feature fails with the error: "This Account lacks sufficient permissions. :: Connect not enabled for account."

Cause

Many DocuSign API integrations make Connect feature related requests (i.e. SAP SuccessFactors, Workday , others.) This error is triggered when an API request is made in order to get, create, update, or delete an Account's DocuSign Connect configuration, but the Connect feature itself is not fully enabled for the Account. 

Specifically, this means the Connect feature is:
  1. Neither Allowed nor Enabled
-OR-
  1. Allowed but not actually Enabled

Resolution

Note: These steps assume you've already confirmed that the integration calling DocuSign's API is in fact pointing to the correct Account and Environment with the correct credentials. If you need help verifying this, please reach out to your internal integration owner/IT before continuing.

You'll need to verify if the cause is #1 or #2:

  1. Log into the DocuSign eSignature account as an Account Administrator.
  2. Click Admin at the top of the page.
  3. Does Connect show in the sidebar under INTEGRATIONS?
DS Admin Integrations Sidebar - Connect
  • If NO, this means Connect is neither Allowed or Enabled (Cause #1) > Move to next step #4.
  • If YES, this means Connect is Allowed but not actually Enabled (Cause #2) > Skip to step #5.
  1. To have Connect Allowed for your Account, you will need to reach out to DocuSign Support or your DocuSign Account Manager. After doing so, continue to step #5.
  2. Click Connect. You should see the message, "Connect not Enabled".
 DS Admin Connect Not Enabled
  1. Click ENABLE CONNECT.
  2. Attempt to use the integration again.

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