DocuSign Insight-SA UI displays an alarm that analytics index is not responding

Issue

When you login to SA, you see message "Alarm: Analytics will resume processing when the problem is resolved"

This issue is applicable to version 6.

 

Cause

Based on the error in the logs, this is determined to be caused by a database connection issue:

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[Curator-Framework-0-SendThread(10.86.0.2:2181)] [INFO] [2019-09-18 01:11:25,826] o.a.z.ClientCnxn: Session establishment complete on server 10.86.0.2/10.86.0.2:2181, sessionid = 0x1000001dfe63e6e, negotiated timeout = 40000
[db connection adder] [ERROR] [2019-09-18 01:11:22,748] o.p.Driver: Connection error:
org.postgresql.util.PSQLException: Connection attempt timed out.
at org.postgresql.Driver$ConnectThread.getResult(Driver.java:416)
 

Solution

Restart the DOOG database