DocuSign Insight-ATN - "Unsupported document found"

Issue

When trying to process a document through ATN, you see the error "Unsupported document found". 
The document is a valid .docx document.
This issue applies to version 5 and 6.

 

Cause

You can get this error message if the import directory set up for ATN is not accessible by all servers.

 

Solution

1. Check the importer settings in the seal-back application.conf file. Ensure the importer path is on a share that is accessible by all servers (the importer path is generally not). It is recommended to use a folder similar to the blobstore with the same share and permission requirements.

2. Check the syntax of the path. Use the \ for the slash in a Windows UNC. You also need to put in two \\ for each \. So the importer UNC path should appear similar to the following:

location = "\\\\MyServer\\ShareName\\dataimport"