DocuSign eSignature for Salesforce - "Unspecified_Error" received when trying to send an envelope

Issue

An error occurs after clicking "Send Now" or "Next" from DocuSign eSignature for Salesforce.

Error

"Unspecified_Error"
User-added image

Cause

This error can occur when anchor tags saved on an account contain an extra curly bracket "{" or "}" in the anchor text. For example: \{test{r}}\
 

Solution

Remove the extra brackets in the Anchor Text.

Steps from Salesforce:

  1. Navigate to the DocuSign Admin object
  2. Click the Custom Tags tab and open the custom tag containing the extra brackets
  3. Scroll down to the Advanced section, and under Anchor Text, remove the extra brackets
  4. Click Save
  5. Repeat the process for any other custom tags
Steps from DocuSign:
  1. Click Admin at the top 
  2. Under Signing and Sending section, click Document Custom Fields
  3. Open the field that needs to be modified
  4. Scroll down to the Advanced section, and under Anchor Text, remove the extra brackets
  5. Click Save
  6. Repeat the process for any other custom tags

Additional Resources