DocuSign for Outlook Add-In Fails to Forward Files in Certain Microsoft Builds

The Add-In for DocuSign for Outlook (application) works as described here

Issue

Some users are experiencing a product issue when forwarding attachments from DocuSign Envelopes when using this Add-In. 

A common way to be in this situation is by following these steps:
  1. Start with an email in Outlook that has an attachment. 
  2. Click "Sign Attachments" from the Outlook menu bar. 
  3. Click the DocuSign "Continue" button and continue signing the attachment file as normal. Click "Finish".
  4. Select "Send Document" from the Outlook side panel. You then see the attachment from the completed DocuSign Envelope as an attachment. This is what we'd expect to see:  
    User-added image
    Instead, it shows like this:
    User-added image
  5. If you were to send the email to any email recipient who is not the sender or a signer in the Envelope, and they try to click on the attachment, it is a URL link instead of an actual, self-enclosed file, so will give that person a 404 Error when trying to open it. 
User-added image

Cause

The cause has been identified as the Build version of the Outlook Application that's running on your computer. Some versions prior to Build # 16.0.8431.2046 have encountered this issue. 

This build version is updated by Microsoft (or your IT team) per the frequency of the channel that you're on. How to switch from Deferred Channel to Current Channel for the Office 365 suite

Solution

Use one of these workarounds, or resolve the issue by upgrading to Build # 16.0.8431.2046 or later of Microsoft Outlook.

Solution #1 - Upgrade to Build # 16.0.8431.2046 or later of Microsoft Outlook. Follow the instructions here, or talk to your local IT if you don't have the Admin Permissions to your local machine. 

Check your Build Version by doing the following: 

  1. Open Outlook (application)
  2. Click on  File > Office Account
  3. The Build version will be listed under Product Information. You'll also see the channel that you're on for updates. 
To Upgrade do the following: 
  1. Open Outlook (application)
  2. Click on  File > Office Account
  3. Click on "Office Options > Update Now".
  4. Follow the on-screen prompts until you see "You're up to date!" Click "Close". 

Solution #2 - Workaround: Use OWA (web-based outlook) to send files instead of the Outlook program/application. 
  1. Login to Office 365 and go to Outlook in a web browser, 
  2. Continue to send files as attachments, normally

Solution #3 - Save locally, then send.

You can download a PDF file from an envelope you've sent, or use any other self-contained file and send it in an Envelope through DocuSign or email and have it successfully send to an email recipient.