DocuSign HSM Appliance (formerly PrivateServer HSM) Special Announcements

Notice: The PrivateServer product is being renamed to HSM Appliance. You will see our documentation and marketing materials take on the new name. Rest assured that they are one and the same product and that support continues as before.

As of September 30, 2016, PrivateServer™ hardware version 4.7 will no longer be available for purchase. We are pleased to inform you that it will be replaced by the new HSM Appliance version 5. For more information please contact us.

As of June 30, 2017 or 3 years from the last purchase date, PrivateServer™ hardware version 4.7 and software version 4.8.2 and below will no longer be supported.

Have an issue? To send us an email, please submit this form.

HSM Appliance version 5 main features:

  • FIPS 140-2 level 3 
  • Hot swappable dual power supply.
  • Touch screen that replaces the need for external keyboard and external monitor.
  • Size of the appliance was reduced to 3U.
  • Upgraded internal hardware that accelerates performance by X3.
  • Higher security by using TLS v1.2 communication protocol between client and PrivateServer.
  • New feature for automatically performing database replication.
  • Full backward compatibility for existing APIs and full migration path from older versions.
  • Free software and discounted hardware upgrades are available for customers under a valid maintenance contract.
  • For more information please fill in our contact us form!
 
Please note:
  • Customers with hardware version 5 can disregard this message.
  • Renewal of maintenance agreement for hardware version 4.7 and below, will include support continuation but will not include component replacements.
  Previous Announcements:
  • As of March 31, 2015, PrivateServer™ hardware version 4.6 and software version 4.6 and below will no longer be supported. We are pleased to inform you that they will be replaced by the upgraded PrivateServer version 4.8.1, FIPS 140-2 LEVEL 3 certified product.
  • As of January 1, 2013, PrivateServer™ Version 4.2 will no longer be available for purchase. We are pleased to inform you that it will be replaced by the upgraded PrivateServer version 4.8.1, FIPS 140-2 LEVEL 3 certified product. For more information please contact us.
  • As of January 1, 2009, ARX will cease its support of PrivateServer™ Version 3.x.
    ARX is moving forward with new security requirements and is happy to inform you about our new PrivateServer version 4, FIPS 140-2 LEVEL 3 certified product.
    The new version includes new and advanced hardware which provides better performance and stability to our users. It is no longer possible to purchase PrivateServer™ Version 3.x. Please consider this a good opportunity to upgrade your End of Life product to PrivateServer™ version 4 at a discounted price.
    Please note that the discounted price is valid only to customers under a maintenance contract. For ARX’s special offers, please contact us.