Error "Attempt to de-reference a null object" when accessing the Account tab within the DocuSign Admin object - DocuSign eSignature for Salesforce

Issue

Unable to access the Account tab within the DocuSign Admin object as the error message "Attempt to de-reference a null object" appears. You might be able to access the other tabs (Settings, Layouts and Users) and launch DocuSign from the DocuSign Admin tab.

User-added image

User-added image

Cause

DocuSign eSignature for Salesforce version 7.0+ might be configured with an incorrect account.

Solution

Reconfigure DocuSign eSignature for Salesforce with the correct DocuSign account.

Steps:
  1. Follow the instructions listed in this article to delete the DocuSign Credentials (access https://{domain}.my.salesforce.com/apex/dsfs__Troubleshooting and Click Delete DocuSign Credentials)
  2. Once the account configuration settings have been cleared, reconfigure DocuSign eSignature for Salesforce with a valid account. 

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