(Vorversion) DocuSign eSignature für Salesforce (DFS) – Connect-Fehler – erforderliche Felder fehlen


Problem

Fehler: (wird im Connect-Protokoll angezeigt)

SalesForceIntegration fehlgeschlagen, Salesforce-Benutzer: dsfs__DocuSign_Empfänger_Status__c fehlgeschlagen, Fehlermeldung: Kann nicht für dsfs__DocuSign_Empfänger_Status__c eingefügt werden, Zusatzinformation: erforderliche Felder fehlen: [dsfs__Übergeordneter_Status_Datensatz__c] (SalesForceIntegration failed, Salesforce User: , dsfs__DocuSign_Recipient_Status__c failed, message: Unable to insert into dsfs__DocuSign_Recipient_Status__c, additional info: Required fields are missing: [dsfs__Parent_Status_Record__c])

Ursache

DocuSign Connect für Salesforce ist möglicherweise nicht richtig konfiguriert. Wenn das Statusdatensatzobjekt (dsfs__DocuSign_Recipient_Status__c) vor dem primären Statusobjekt (dsfs__DocuSign_Status__c) initiiert wird, kann keine richtige Verknüpfung hergestellt werden. Dadurch können Statusobjekte nicht richtig erstellt oder aufgefüllt werden.

Screenshot

Lösung
Öffnen Sie Einstellungen > Connect > Salesforce. Connect-Objekte werden aufgeführt und können neu angeordnet werden, indem Sie sie per Drag-and-drop neu sortieren. Das Statusobjekt sollte zuerst aufgeführt werden, gefolgt vom Empfängerstatusobjekt und danach die benutzerdefinierten Objekte.
Sobald die Connect-Objekte richtig angeordnet sind, führen Sie einen Sendetestdurchlauf aus oder publishen Sie Umschläge. Prüfen Sie anschließend das Protokoll.
Der Fehler kann auftreten, wenn dsfs__DocuSign_Status__c falsch konfiguriert wurde oder Informationen fehlen.

So testen Sie die Konfiguration und Informationen:

  1. Deaktivieren Sie das aktuelle Objekt dsfs__DocuSign_Status__c object und die Objekte dsfs__DocuSign_Recipient_Status__c.

  2. Wählen Sie „Neues Objekt > DocuSign eSignature für Salesforce”.

  3. Aktivieren Sie das neue Objekt: Aktionen > Aktivieren.

  4. Wenn benutzerdefinierte Objekte verwendet werden, fügen Sie diese dsfs__DocuSign_Status__c hinzu.

  5. Führen Sie einen erneuten Test durch.

Der Fehler kann aber auch verursacht werden, wenn die Einstellungen für Empfängerstatusobjekt und DocuSign-Statusobjekt nicht übereinstimmen. Hierzu müssen die aktivierten Ereignisse und die Einstellungen „Nur nach Abschluss” beider Objekte übereinstimmen.