Por que o erro "Não foi possível adicionar/atualizar os envelopes do DocuSign" é exibido? – DocuSign eSignature para Salesforce

Problema

No DocuSign eSignature para Salesforce, o seguinte erro é exibido:

"Erro: Não foi possível adicionar/atualizar os envelopes do DocuSign. DocuSign_Envelope_c: sem acesso de exclusão. Não é possível adicionar/atualizar documentos. DocuSign_Envelope_Document_c: sem acesso de exclusão. Não é possível adicionar/atualizar destinatários. DocuSign_Envelope_Recipient_c: sem acesso de exclusão".

Causa

Este erro indica que o perfil de permissão do Salesforce do usuário não tem permissão de exclusão para os objetos listados.

Solução

Como administrador do Salesforce, atualize as permissões de objeto personalizado para o usuário.

  1. Faça login no Salesforce, clique no nome do perfil e em Configuração.
  2. Em Configuração de administração, clique para expandir Usuários e clique em Perfis.
  3. Clique no perfil afetado.
  4. Clique em Editar na parte superior da página.
  5. Navegue até a seção Permissões de objeto personalizado próximo à parte inferior da página e marque a caixa para Excluir em cada objeto afetado pela mensagem de erro (Envelope do DocuSign, Documento do DocuSign, Destinatário do DocuSign).
  6. Clique em Salvar.