Incapaz de autenticar por meio de integração de parceiro - O URI de redirecionamento não está registrado corretamente com DocuSign

Problema

O URI de redirecionamento não está registrado corretamente no DocuSign
login failure

Causa

A integração mal configurada não consegue concluir o fluxo de trabalho de autenticação corretamente. Os URIs de redirecionamento devem ser associados a uma chave de integração antes que possam ser usados para autenticação.

Solução

Se você for um usuário final, não será capaz de resolver o problema sozinho.

  • Se esse problema estiver ocorrendo inteiramente no DocuSign, abra um caso com o Suporte do DocuSign para investigação.
  • Se esse problema estiver ocorrendo ao tentar autenticar por meio de uma integração de parceiro, você precisará entrar em contato com o proprietário dessa integração para relatar esse erro.
  • Se a integração for de propriedade e desenvolvida pela DocuSign (como DocuSign eSignature for Salesforce ou DocuSign for Outlook), abra um caso com o Suporte DocuSign.

Ao relatar esse erro para o DocuSign ou um desenvolvedor externo, inclua o URL completo da página na qual você está recebendo o erro.

Se você é um desenvolvedor / proprietário da integração

Existem duas causas principais para esse erro: um URI incorreto está sendo passado para o DocuSign ou um URI correto não foi registrado para a chave de integração.

Para verificar se um URI foi registrado para a chave de integração:

  1. Faça login na conta DocuSign que possui a integração (no ambiente correto: Demo ou Prod).
  2. Selecione Ir para Configurações > Aplicativos e Chaves
  3. Clique em Ações > Editar ao lado da chave de integração em questão
  4. Compare o URI gerado pelo seu aplicativo com a lista de URIs registrados
  5. Clique em Adicionar URI e preencha o URI ausente