Erro de integração de recurso Connect e API do DocuSign: esta conta não tem permissões suficientes – o Connect não está habilitado para a conta

Problema

Uma integração que usa os recursos API e Connect do DocuSign falha com o erro: "Esta conta não tem permissões suficientes. :: O Connect não está habilitado para a conta".

Causa

Muitas integrações da API do DocuSign fazem solicitações relacionadas ao recurso Connect (ou seja, SAP SuccessFactors, Workday etc.) Esse erro acontece quando uma solicitação à API é feita para obter, criar, atualizar ou excluir uma configuração do DocuSign Connect da conta, mas o recurso Connect em si não está totalmente habilitado para a conta.

Especificamente, isso significa que o recurso Connect é:
  1. Não permitido nem habilitado
- OU -
  1. Permitido, mas não habilitado de fato

Resolução

Observação: essas etapas presumem que você já confirmou que a integração que está chamando a API do DocuSign está, na verdade, apontando para o a conta e o ambiente corretos com as credenciais certas. Se você precisar de ajuda para verificar isso, contate o proprietário interno da integração ou a TI antes de continuar.

Você precisará verificar se a causa é a 1 ou a 2.

  1. Faça login na conta do DocuSign eSignature como administrador da conta.
  2. Clique em Administrador no topo da página.
  3. O Connect aparece na barra lateral sob INTEGRAÇÕES?
DS Admin Integrations Sidebar - Connect
  • Se NÃO, o Connect não é Permitido nem está Habilitado (causa nº 1) > Vá para a próxima etapa nº 4.
  • Se SIM, o Connect é Permitido, mas não está Habilitado (causa nº 2) > Vá para a etapa nº 5.
  1. Para permitir o Connect para a sua conta, é preciso criar um caso com o suporte DocuSign. Depois de fazer isso, prossiga para a etapa nº 5.
  2. Clique em Conectar. Você deverá ver esta mensagem: "Connect não habilitado".
DS Admin Connect Not Enabled
  1. Clique em HABILITAR O CONNECT.
  2. Tente usar a integração novamente.

Recursos