DocuSign eSignature for Salesforce - Update failure - Unmanaged custom object tab already exists

 

Issue

Errors will either be shown in the browser or delivered via email. Other tabs may be mentioned​

(DocuSign_Envelope_Recipient__c) Unmanaged custom object tab already exists, package upgrade cannot create another tab
DocuSign_Envelope_Recipient__c: Unmanaged custom object tab already exists, package upgrade cannot create another tab

(DocuSign_Envelope__c) Unmanaged custom object tab already exists, package upgrade cannot create another tab
DocuSign_Envelope__c: Unmanaged custom object tab already exists, package upgrade cannot create another tab

 

Cause

Unknown. Believed to be caused by a faulty initial installation.


Solution

You may be able to delete the tabs referenced in the error.

To check, navigate to Salesforce Setup > Customize > Tabs, and look for any DocuSign tabs called out in the error message. If they do not have the Managed Package Icon, there will be a link to delete them.
If you are able to delete the tabs, attempt the update installation again.

If you are unable to delete the tabs, or if deleting the mentioned tabs fails to resolve the error, please open a case with DocuSign Support referencing this article and including the following:
  • Current DocuSign eSignature for Salesforce version (Available from Setup > Installed Packages)
  • Full error text
  • Troubleshooting steps attempted