DocuSign Print Driver Version v2.x System Requirements

Warning: This version of DocuSign Print Driver is no longer supported.  Please download and install the latest version.

The DocuSign Print Driver version v2.x  is compatible with Internet Explorer only. The DocuSign Print Driver is NOT compatible with Mac, Citrix, or remotely located single-server systems.

.NET 4.0 is required for all Print Driver versions and will be installed during the Print Driver installation.

System requirements:  

  • 32-bit version: Windows® 7, Windows® 2008, Vista, XP, 2003, 2000

  • 64-bit version: Windows® 7, Windows® 2008, Vista, XP, 2003

Note: The DocuSign Print Driver has not been tested on Windows 8 releases but should function correctly on Windows 8 platforms.

Browser:

  • Microsoft® Internet Explorer® 7 or later

For more information or to download the Print Driver, check out the Print Driver Quick Start Guide.