DocuSign eSignature für Salesforce – Warum erhalte ich die Fehlermeldung „DocuSign-Umschläge können nicht hinzugefügt/aktualisiert werden“?

Problem

Sie erhalten in DocuSign eSignature für Salesforce die folgende Fehlermeldung (oder ähnlich):

Fehler: DocuSign-Umschläge können nicht hinzugefügt/aktualisiert werden. DocuSign_Envelope_c: kein Zugriff zum Löschen. Dokumente können nicht hinzugefügt/aktualisiert werden. DocuSign_Envelope_Document_c: kein Zugriff zum Löschen. Empfänger können nicht hinzugefügt/aktualisiert werden. DocuSign_Envelope_Recipient_c: kein Zugriff zum Löschen.

 

Ursache

Dieser Fehler tritt auf, wenn dem Salesforce-Berechtigungsprofil des Benutzers die Löschberechtigung für die aufgeführten Objekte fehlt.
 

Lösung

Aktualisieren Sie als Salesforce-Administrator die Benutzerberechtigungen für benutzerdefinierte Objekte.

  1. Melden Sie sich bei Salesforce an, klicken Sie auf den Profilnamen und danach auf Setup.
  2. Klicken Sie im Bereich „Einrichten der Verwaltung“ zum Erweitern auf „Benutzer verwalten“ und danach auf Profile.
  3. Klicken Sie auf das gewünschte Profil.
  4. Klicken Sie im oberen Seitenbereich auf Bearbeiten.
  5. Aktivieren Sie im unteren Seitenbereich im Bereich „Benutzerdefinierte Objektberechtigungen“ für jedes Objekt, das von der Fehlermeldung betroffen ist, das Kontrollkästchen Löschen (DocuSign-Umschlag, DocuSign-Dokument, DocuSign-Empfänger).
  6. Klicken Sie auf Speichern.